Balsamiq

Toggle navigation

Backups and The Support Folder



Balsamiq Wireframes for Desktop automatically backs up every local file you open, and automatically saves every change you make to those files. It saves those files in the Support Folder. In the event that something happens to your original .bmpr project file, you can go into this backup and recover an up-to-date version of the project.

How to Find the Support Folder

While you can browse to the folder manually, the fastest way to open it is to open the About dialog in the Balsamiq Wireframes for Desktop App.

On macOS, click on Balsamiq Wireframes > About.

On Windows, click on Help > About Balsamiq Wireframes.

Once you have the About dialog open, click on the Open Support Folder link.

os

In the event that you cannot open Balsamiq Wireframes for Desktop, here are actual locations of the Support Folder for various platforms:

  • macOS: <your user>/Library/Application Support/Balsamiq Wireframes
  • Windows: <user folder>\AppData\Roaming\Balsamiq\Balsamiq Wireframes\

How to Unhide those folders

Adding a layer of complication to manually browsing to the folders is the fact that macOS and Windows sometimes hide the folders that the Support Folder lives in. Here is how to unhide them:

macOS

On macOS 10.7 and higher: the ~/Library folder is hidden by default. You can access it by opening a Finder window, clicking on the Go menu option at the top of your screen, and then pressing the option key on your keyboard. That will make the Library folder selectable in the dropdown menu.

Windows

In Windows, you need to "unhide system files.""

  1. Open Windows Explorer (Start+E)
  2. Select the menu item "Organize > Folder and search options."
  3. Select the View tab, and uncheck "Hide protected operating system files."

The AppData folder should appear in your user folder in your Windows Explorer now. If it doesn't, you may need to restart.


Accessing the Backups

You'll find the backup of your project in one of two folders in the Support Folder.

  • The LocalFiles Folder: The LocalFiles folder is for projects that you have saved at least once. We keep projects in this folder for about a week before deleting them.

  • The UnsavedFiles Folder: The UnsavedFiles folder is for projects that you haven't had a chance to save yet, but have been working on. Check here if you re-opened Balsamiq Wireframes for Desktop, but your new project didn't open up with it.

These backups are stored for (around) seven days, and should automatically load in case of a corrupted project file.

Restoring Backups

Check both the LocalFiles and UnsavedFiles folders for your project. The project files will have long, randomized names which we use internally to ensure the names are unique.

  1. Select all .BMPR files in LocalFiles and copy them. Next, navigate to a temporary folder/directory on your hard disk and paste the files you copied.

    You could use an existing location (for example the default '~/Downloads/' folder on macOS or the default 'Downloads' directory in Windows) or create a folder or directory temporarily just for this. Repeat the copy and paste for the projects in UnsavedFiles.

  2. Find the backup file containing your wireframes. For convenience, you may want to start with the largest file or you may want to pick a file - based on its date and time - that is most likely to contain the bulk of your work. Or, you may wish to simply open every single file and check to see which one is the closest match.

  3. Once you've found your wireframes, save the project with a more meaningful name via the menu: File > Save As...

  4. Finally, you can delete all of the projects with randomized names from this temporary working folder and, optionally, copy your recovered project to a known location e.g. '~/Documents/Wireframe Projects'