Balsamiq for Desktop Docs > Exporting

Exporting



The Export menu contains the following export options:

os

Read on for descriptions of all of the options or skip ahead using the links below.


Exporting to PDF

You can export the wireframes in your project as a PDF, which can be useful for printing, sending by email, presenting to clients, or posting online. The PDF will be created in high resolution and with selectable text (good for your team to copy/paste from).

If your wireframes contain links, these will work in your exported PDF as well, which will allow you to create click-through prototypes of your designs. (To learn more about linking, see Linking wireframes Together.)

Note: Links may not work in the default Windows 8 or 10 PDF viewer. If this happens, you can download Adobe Acrobat or one of the many other free PDF viewers.

To export to PDF select the File > Export to PDF... menu option (shortcut CTRL/+P). Each wireframe will be displayed on a separate page of a PDF document. The wireframes will be in the same order as in the project, so arrange them in the order you'd like before exporting.

You can choose to export all wireframes or a subset, including any alternates you have created.

The PDF export options are shown here.


Exporting to an Image

To save one or all of your wireframes as image files, choose one of the export to PNG commands from the File > Export menu:

  • Export > Current wireframe to PNG... will save the selected wireframe in PNG image format
  • Export > All wireframes to PNG... will save all of the wireframes in your project as separate image files

Note: If you check the "Use Transparent Background" option (in the Project > Export menu), the exported image(s) will be transparent anywhere the canvas shows through in the wireframe.

The shortcuts for exporting a wireframe and project to image files are CTRL/+R and CTRL/+SHIFT+R, respectively. Exporting all wireframes will also generate images for any alternates you have created.

You can also export a subset of the controls in your wireframe by selecting them on the canvas and using the Export Current wireframe to PNG command. The export dialog will ask you if you want to export only the selected controls or the entire wireframe.


Printing

The Balsamiq Wireframes editor does not support printing directly to a printer. Instead you can export to PDF and print from your favorite PDF viewer.


Exporting Wireframes to Another Project

Sometimes you might want to copy or move a wireframe (or a few) from one project to another. Here are a couple of ways to do it.

Copying and Pasting

  1. Open the two projects (each in its own browser tab or window)
  2. In the source project, select the wireframe(s) you want to copy or move
  3. Copy the wireframe(s) (CTRL/+C)
  4. In the target project, paste your wireframe(s) (CTRL/+V)

That’s it! You may now delete the wireframe(s) from the source project if you wish.

This simple method works across all our Balsamiq Wireframes products.

Dragging and Dropping

Alternatively, you can can also drag and drop wireframes from one project to another (and then delete the wireframe(s) from the source project if you wish).

This method works only for Balsamiq Wireframes for Desktop.

Note: Both methods include the transfer of Symbols and Assets/Images during the process so no need to worry about those.


Exporting a Project to Other Balsamiq Products

You can easily export a project to another Balsamiq product (using the .bmpr extension) by moving/uploading your .bmpr file there.